Det går inte att hitta någon ClipArt i Word Online eller OneNote Online att infoga

Symptom

Tänk dig följande scenarier:

Scenario 1

Du har en server som kör Microsoft Office Online. Du öppnar antingen Microsoft Word Online eller Microsoft OneNote Online och klickar sedan på Knappen ClipArt. Men när du söker efter ett objekt returnerar sökningen inga ClipArt-resultat.

Det här beteendet inträffar när Knappen ClipArt är aktiverad.

Scenario 2

Du har en server som kör Microsoft Office Online. När du öppnar Microsoft Word Online eller Microsoft OneNote Online och försöker infoga ett ClipArt-objekt är Knappen ClipArt inaktiverad.

Orsak

Det här problemet beror på att tjänsten hämtar ClipArt genom att kontakta Office Online direkt från Microsoft SharePoint-servern. Brandväggs- eller proxyregler kan dock förhindra utgående trafik från att nå de url:er som krävs.

Lösning

Om du vill undvika det här problemet kontrollerar du att du har åtkomst till alla tre nödvändiga URL:er från den dator som kör SharePoint-servern. Kontrollera dessutom att proxyinställningarna är konfigurerade på rätt sätt för servern. Gör så här:

  1. Logga in på den dator som är värd för Word Online eller OneNote Web App.

    Observera Detta är vanligtvis en klientdelsdator.

  2. Kontrollera att du kan bläddra till följande tre URL:er i en webbläsare:

  3. Om du inte kan komma åt dessa URL:er från en webbläsare kan brandväggen blockera åtkomsten till dessa webbplatser. Ändra inställningarna i brandväggen för att aktivera åtkomst till var och en av dessa URL:er.

Ofta måste utgående trafik använda en proxy för att nå dessa URL:er. För att instruera OneNote Online att använda en proxy använder du följande cmdlet för varje webbplats där OneNote Online är aktiverat:

PS C:\> Set-SPOneNoteWebAppConfig -Site "http://localhost" -Proxy "http://myproxyURL"

**Note** You can check the current proxy settings by using the following cmdlet:

```powershell
PS C:\> $w = Get-SPOneNoteWebAppConfig -Site "http://localhost"

PS C:\> $w.Properties